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1. OVERVIEW

1.1. Scope of This Document
This document is intended to guide Managed Service Providers through the
integration process between ConnectWise Automate and GravityZone Control
Center.
The Bitdefender integration plugin allows you tomanage endpoint security through
ConnectWise Automate.
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2. REQUIREMENTS
The ConnectWise Automate integration requires the following:

● GravityZone license key or valid MSP subscription. If you do not have a valid
MSP subscription, you can find out more information on the Bitdefender MSP
program. Integration is available for Partner companies.

● GravityZone set up into your environment.

● ConnectWise Automate v11 or newer.

● Location cache for Bitdefender security agent deployment enabled.
During deployment, the Bitdefender security agent installer downloads a large
file size to each targetmachine. Enable the followingcheckboxes inConnectWise
Automate to configure a location cache for the Bitdefender security agent
deployment:

– Cache External URLs

– Cache LabTech Server Downloads
Formore information, refer toCaching inConnectWiseAutomateDocumentation.

ConnectWise Automate Template Config

Requirements 2
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3. SETTING UP THE INTEGRATION
To integrate GravityZone Control Center with ConnectWise Automate, follow the
steps below:

3.1. Plugin Installation via Solution Center
1. Log in to AutomateControl Center and navigate toSystem>Solutions > Solution

Center.

2. In Solution Center go to Security.

3. Choose GravityZone Cloud Security from the Security Solutions options.

Security Solutions in Solution Center

4. Click Queue to add this solution in queue.

Setting Up the Integration 3



Bitdefender Cloud Security

The Solution Center displays 1 Solution in Queue in the upper left corner.

5. In the Queued Solutions section, click Install/Update.

Queued Solutions in Solutions Center

6. Navigate to System > Solution > Plugin Manager.

7. Find Bitdefender GravityZone plugin, right-click on it and select Enable.

8. Find Bitdefender GravityZone Remote Agent plugin, right-click on it and select
Enable.

Setting Up the Integration 4



Plugin Manager

9. A confirmation window prompts you to restart the Control Center. Select No.

Note
Restarting the Database Agent terminates any scripts running at that time.

10. Navigate to Advanced > Reload Plugins and select Update Remote Agent
Plugins.
This restarts the Database Agent and Remote Plugins.

11. Restart IIS server.

12. Close and re-open the Automate Control Center.
Continue configuring the integration.

Important
The above procedure also applies when updating the Bitdefender plugin. Restarting
the Database Agent, IIS server and the Control Center is mandatory for completing
the update.
To check if the installation or the update of the Bitdefender plugin has completed
successfully:

1. Go to Tools > Bitdefender GravityZone.

2. In the left-side menu, go to Other > Plugin Status.

3. Verify the components statuses and, in case of issues, take actions as indicated
in Recommendations. Once done, restart the ConnectWise Automate Control
Center.

3.2. Manual Installation of the Plugin
The following steps describe how to install the Bitdefender plugin manually:

1. Download the Bitdefender plugin and extract the archive.

2. In Automate Control Center, navigate to System > Solutions > Plugin Manager.

Setting Up the Integration 5
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3. Click Advanced in the upper right-hand corner.

4. Navigate toManage Plugins > Add Plugin.

5. Navigate to the folder where you extracted the Bitdefender plugins and select
Bitdefender GravityZone.dll.

A confirmation dialog appears.

6. Click Yes to confirm the action.
The Bitdefender GravityZone plugin will appear under the Name column.

7. Repeat steps 2 – 5 and select Bitdefender GravityZone Remote
Agent.dll to install the remote agent.

TheBitdefender GravityZoneRemote Agentwill appear under theName column.

8. Navigate to Advanced > Reload Plugins and select Update Remote Agent
Plugins.
This restarts theDatabaseAgent andRemotePlugins, and updates the plugins.

9. Restart IIS server.

10. Close and re-open the Automate Control Center.

Important
The above procedure also applies when updating the Bitdefender plugin. Restarting
the Database Agent, IIS server and the Control Center is mandatory for completing
the update.
To check if the installation or the update of the Bitdefender plugin has completed
successfully:

1. Go to Tools > Bitdefender GravityZone.

2. In the left-side menu, go to Other > Plugin Status.

3. Verify the components statuses and, in case of issues, take actions as indicated
in Recommendations. Once done, restart the ConnectWise Automate Control
Center.

3.3. Plugin Update
Every time a new version is available, you can update the Bitdefender plugin via
Solution Center or manually.

Setting Up the Integration 6



● To update the Bitdefender plugin via Solution Center, follow the same procedure
as described at “Plugin Installation via Solution Center” (p. 3).

● To update the Bitdefender plugin manually, follow the same procedure as
described ar “Manual Installation of the Plugin” (p. 5).

In both cases, to complete the update successfully, youmust restart the Database
Agent, IIS server and the Automate Control Center.
To check if the update of the Bitdefender plugin has completed successfully:

1. Go to Tools > Bitdefender GravityZone.

2. In the left-side menu, go to Other > Plugin Status.

3. Verify the components statuses and, in case of issues, take actions as indicated
in Recommendations. Once done, restart the ConnectWise Automate Control
Center.

3.4. Configuring the Integration
ConnectWise Automate requires access to GravityZone services. To authorize
access you need to generate anAPI key inGravityZoneControl Center and configure
the integration.
Configure the integration as follows:

● Generate API Key

● Configure Package Defaults

● Configure Plugin Settings

● Configure Alert Settings

● Configure Client Mapping

● Configure Computer Mapping

● Review Plugin Status

3.4.1. Generating the API Key
1. Log in to GravityZone Control Center using your Partner account credentials.

2. Click the username at the upper-right corner and chooseMy Account.

3. Go to the API keys section and click Add at the top side of the table.

Setting Up the Integration 7



4. Enable the following APIs:

● Companies API

● Licensing API

● Packages API

● Network API

● Integrations API

● Policies API

● Reports API

● Accounts API

● Incidents API

● Quarantine API

● Event Push Service API

GravityZone Control Center API Configuration

5. Click Save.

Setting Up the Integration 8



An API key is generated. To prevent the leaking of sensitive information, do not
share or distribute your own generated API keys.

6. Copy the Access URL from the Control Center API section.

3.4.2. Configuring Plugin Settings
The Plugin Settings page contains data necessary to connect ConnectWise
Automate to GravityZone, like access URL, API key and installation options for the
Bitdefender security agent.

1. In ConnectWiseAutomate Control Center, go to Tools > Bitdefender GravityZone
> Plugin Settings.

Plugin Settings

2. Under API Options, enter the URL of GravityZone console along with the
generated API key and click Validate.

3. Under Installation Options, select Automatically reboot if needed. This option
is useful when the computer needs to restart following the Bitdefender security
agent installation. If you leave this check box unselected, the endpoint will
remain unprotected until the next manual reboot.

4. Click Advanced Settings at the upper right corner of the screen for more
deployment options:

a. In the new window, next to Automatic Deployment Retry, select the time
interval on which the Bitdefender security agent will try again to install if an
error occurs.

Setting Up the Integration 9



b. Next to Download Timeout, select a time limit within which the installation
package should be downloaded.

c. Use theOn/Off switch to enable or disableSetupDownloader for the security
agent deployment.
When Setup Downloader is enabled, the Bitdefender plugin uses this file to
deploy the Bitdefender security agent on Windows and macOS computers
instead of the full kit.

Note
The Enable Setup Downloader option does not support Linux. On computers
running Linux, the plugin continues using the full kit when deploying the
Bitdefender security agent.

d. Click Save to apply the changes and to close the window.

Plugin Settings

5. Click Save Settings in the upper right corner of the screen to confirm changes.

3.4.3. Configuring Alert Settings
In the Alert Settings page you can configure the Bitdefender plugin to send you
alerts based on push notifications from GravityZone protection modules.

1. Click Detect URL to auto discover the ConnectWise Automate Server and verify
that the Callback URL field contains the correct address.

Setting Up the Integration 10



Alert Settings

2. Select the number of days for keeping old data (up to 120 days).

3. Select check boxes to enable alerts for specific security events and forBlocked
Threats or Current Threats (which are still present on computers). Alerts are
available for the following security events:

● Advanced Threat Control

● Advanced Anti-Exploit

● Antimalware

● Antiphishing

● Endpoint Detection and Response (EDR)

● Hyper Detect

● Network Attack Defense

● Ransomware Mitigation

● Web Traffic Scan
For certain security events, such as Antiphishing, Ransomware Mitigation and
Web Traffic Scan, you can only select Blocked Threats, as Bitdefender
automatically takes action without waiting for user interaction.

Setting Up the Integration 11



For EDR incidents, you can only enable alerts for all threats, with no option to
select separately the blocked or current ones. This limitation is due to the
complex nature of the EDR incidents, on which Bitdefender may take actions
while monitoring and reporting them. Therefore, in order to have a complete
incident coverage, it is critical to receive alerts for both current and blocked
threats. Learnmore about EDR incidents in ConnectWise Automate integration.

4. Click Save Settings at the upper right corner of the screen to confirm your
selection.

You can see the security events related to alerts in the GravityZone tab of the Client,
Location and Computer screens. For details, refer to “Security Events” (p. 27).

3.4.4. Configuring Package Defaults
The integration creates a new deployment package in the GravityZone Control
Center for each mapped Client or Location. Configure deployment packages to
install the Bitdefender security agent on target machines

1. In Automate Control Center navigate to Tools > Bitdefender GravityZone.

2. Go to Package Defaults.

Package Defaults

3. Under Language, select the package language from the dropdown menu.

4. UnderModules, select the protection module enabled in the default package.

Setting Up the Integration 12
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5. Under Installation, choose to uninstall existing security products or deploy on
top of them.

6. Under Settings, you can set an uninstall password for the security agent.

7. Click Save Settings in the upper right-hand corner to confirm changes.

Making changes in the Package Defaults page does not update deployment
packages already existing in the GravityZone console. In this situation, you need
to either manually update them in the GravityZone console or to re-create them.
To re-create a package, follow these steps:

1. Delete the ConnectWise Automate deployment package from the GravityZone
console.

2. In Automate Control Center, go to Tools > Bitdefender GravityZone > Auto
Deployment.

3. Click Refresh Package List.
The plugin will recreate the deployment package based on the settings from
the Package Defaults page.

3.4.5. Configuring Client Mapping
TheBitdefender plugin creates company records for existingConnectWiseAutomate
clients within GravityZone Control Center. You can control the creation of these
company records using the settings on the Client Mapping page. Also, during this
process, you can configure the product type or subscriptions for the newcompanies.

Setting Up the Integration 13



Client Mapping

To automatically configure GravityZone companies associated with ConnectWise
Automate clients, click the Auto Map button in the upper right corner of the page.
Subsequent dialogs will ask you if you want to create GravityZone companies with
random names and location based groups.
Tomanually configureGravityZonecompanies for clientswithout previousmapping:

1. In theBitdefender GravityZoneCompany column, click the corresponding entries
for Automate clients.

2. From the drop-down menu, choose one of the options:

● Create Customer Record - creates a new company in GravityZone.

● Ignore Customer - excludes that client from the mapping process (when
using Auto Map, for example).

● Select a GravityZone company already created to associate it to the
ConnectWise Automate client.

3. Optionally, in the Create Location based Group in GravityZone column, select
the check boxes for clients for which you want this setting.

4. Click the Save Client Mappings button. A configuration wizard will guide you
through the synchronization process, which implies selecting the product type
for the new companies and the available features. Follow the on-screen
indications:

Setting Up the Integration 14



a. Select the product. Depending on the product type, the Bitdefender security
agent installed on computers belonging to that company will have certain
features enabled.
The following product types are available:

● Endpoint Security, the fully-featured security solution, with all modules
available for deployment onmachines runningWindows, Linux ormacOS.

● Bitdefender EDR, a lightweight Endpoint Detection and Response (EDR)
solution for Windows-based systems that can run alongside any
third-party protection platform.

Click Continue.

b. Select what add-ons to be available with the product type. Depending on
the add-ons, you will be able to install the Bitdefender security agent with
certain features.
Click Continue.

c. Configure the deployment package:

i. Choose the default settingsor customize the packageby selecting certain
modules and options.
Click Continue.

ii. Set preferences for installing andupdating theBitdefender security agent.
Click Continue.

The plugin will create one or more companies in GravityZone having the
specifiedproduct type. TheBitdefender security agent installedon computers
within these companies will have features as configured in the wizard.

In case of clients already associated to GravityZone companies, changing the
mapping does not move any installed Bitdefender agents to the newly selected
companies within GravityZone Control Center. To show under the new company
in GravityZone, you must uninstalled and then reinstall the Bitdefender agents.
Once a company mapped, you can reconfigure the product type and the available
Bitdefender services in the Client Subscriptions page.

Note
The Bitdefender plugin provisions companies for MSPs using Monthly Subscription,
Monthly Subscription Trial, and Monthly License Trial.
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3.4.6. Configuring Client Subscriptions
On the Client Subscriptions page you can control, through the Bitdefender plugin,
the product type and the services enabled on clients.

Client Subscriptions

Configuring Services
To reconfigure the Bitdefender services for a client without changing the product
type:

1. In the upper left-side corner of theClient Subscriptions page, click to view clients
by product type.

2. Select or deselect the check boxes corresponding to the services you want to
enable.

3. Click the Save Settings button.

Note
This operation does not automatically update the existing deployment packages.
When creating a new package, you need to enable the correspondingmodules in the
Package Defaults page.

Changing the Product Type
To change the product type for a client:

1. In the upper left-side corner of the page, click to view clients by product type.

Setting Up the Integration 16



2. Select the client whose product you want to change.

3. Click the Change Product button. A wizard will guide you shows up. Follow the
on-screen indications:

a. Select the product. The following product types are available:

● Endpoint Security, the fully-featured security solution, with all modules
available for deployment onmachines runningWindows, Linux ormacOS.

● Bitdefender EDR, a lightweight Endpoint Detection and Response (EDR)
solution for Windows-based systems that can run alongside any
third-party protection platform.

Click Continue.

b. Select what add-ons to be available with the product type. Depending on
the add-ons, you will be able to install the Bitdefender security agent with
certain features.
Click Continue.

c. Configure the deployment package:

i. Choose the default settings, or customize the package by selecting
certain modules and options.
Click Continue.

ii. Set preferences for installing andupdating theBitdefender security agent.
Click Continue.

The product will change for that client.

After changing the product, you need to you need to reconfigure the Bitdefender
security agent installed on computers fromGravityZone in order to include the new
features. The existing product and its features expire in seven days.

Note
In case your license does not allow changing the product type for managed clients,
the Reconfigure Client button replaces Change Product on the Client Subscriptions
page. That means you can only modify the add-ons and the other settings within the
existing product.
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3.4.7. Configuring Computer Mapping
The integration automatically creates a record in Automate Control Center for
computers with the Bitdefender security agent installed and maps computers
associated with the GravityZone Control Center.
Computer mapping is required for the following functionalities to work correctly:

● Manage Quarantine

● Queue scans

● View security event history

● Alerts and Monitors to function correctly

If the Automatic Mapping is unable to create a successful mapping, you can
manually adjust this by completing the following steps:

1. ClickChangeComputerMappingon theBitdefender tab on theComputer screen.

2. From the dropdown list select the target device in the GravityZone Control
Center that you wish to link to

3. Select Save in the upper right-hand corner of the window to save the changes
and close the window.

3.5. Configuring Deployment
The integration allows you to deploy theBitdefender security agent to yourmanaged
machines in Automate Control Center.

3.5.1. Auto Deployment
The integration uses Auto Deployment to install the Bitdefender agent on new
unprotected machines. The deployment attempts to install the Bitdefender agent
once per day only if it is enabled for the specific location, and the target Computer
has not been excluded.
You can select Auto Deployment for Windows workstations and servers, macOS,
and Linux machines.

1. In Automate Control Center navigate to Tools > Bitdefender GravityZone.

2. Go to Auto Deployment.

3. Select the checkboxes corresponding to your target machines.
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Auto Deployment

4. Click Save Settings in the upper right-hand corner to confirm changes.
Once enabled the automatic deployment starts within 10 to 15 minutes.

3.5.2. Deployment Actions
In the Deployment Actions section, you can manually start installation or
uninstallation commands on machines, clients, or locations. Use the right-side
menu to make specific selections.
To install the GravityZone agent:

1. Select one or more targets.

2. Click Install GravityZone.

An install task starts for selectedmachines. ConnectWise Automate Control Center
must remain open until the installation is complete to avoid aborting the process.
To uninstall the GravityZone agent:

1. Select one or more targets.

2. Click Uninstall GravityZone.

3. Specify the uninstall password, if configured. If not, select Uninstall Password
is not configured.

4. Click Uninstall.
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An uninstall task starts for selected machines.
The Deployment Actions page displays several statuses that indicate if the
GravityZone protection is present on machines or not: Installed, Not Installed,
Installedwith Issues (related tomacOS permissions for full disk access and kernel
extensions, and to Linux critical services not started: bdsrvscand, epagd or
bdlogd), Install Pending, Uninstall Pending.

3.5.3. Deployment Exclusions
In this section, you can exclude machines, clients, and locations from installing
theGravityZone agent on them.Use the right-sidemenu tomake specific selections.
To exclude certain machines from agent installation:

1. Select one or more machines.

2. Click Enable Exclude.

To remove an exclusion:

1. Select one or more excluded machines.

2. Click Disable Exclude.

Note
The Deployments Exclusions in the Bitdefender GravityZone dashboard and in the
Client and Location screens.

3.5.4. Deployment History
This section displays the list of install and uninstall commands started onmachines
in the past. Each entry provides you the following details:

● Client name

● Location

● Computer name

● Command type (installation or uninstallation)

● Command status (whether the command was successful, failed or it is
pending/executing)

● Output details

● Date and time of task completion.

Setting Up the Integration 20



Note
The Deployments Exclusions in the Bitdefender GravityZone dashboard and in the
Client and Location screens.

3.6. Reviewing Plugin Status
The Plugin Status page provides you the insight and the tools to fix issues that
may affect the ConnectWise Automate integration with Bitdefender GravityZone.

Plugin Status

1. In ConnectWiseAutomate Control Center, go to Tools > Bitdefender GravityZone
> Other > Plugin Status.

2. In the table, look for issuesmarked in red. Consult the recommendations below
the table and act depending on the issue.
Solutions include:

● Enabling the Bitdefender GravityZone and Bitdefender GravityZone Remote
Agent components of the plugin

● Restaring the database agent

● Reloading ISS (Web Server)

A similar page to Plugin Status will automatically appear on the Client, Location
andComputer screens every time an issue occurs and requiresmanual intervention.
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4. USING THE INTEGRATION
This section highlights the available features and configuration options for the
following screens:

● Client

● Location

● Computer

In themainwindowof ConnectWise Automate Control Center, double-click a client,
a location, or a computer to access the corresponding screen.

4.1. Client Screen
The Bitdefender GravityZone tab from the Client screen allows you to perform
several tasks and view security events information.

● Configure manual deployment or removal of the Bitdefender agent for one or
more devices

● Configure deployment exclusions

● View deployment history

● Create scan tasks and take certain actions on multiple devices

● Manage the quarantine for the client

● View security events
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Deployment Actions in Client Screen

Additional details relating to each of the Sub-sections on this screen can be found
throughout this document.

Note
For uninstalls you will be prompted to enter an uninstall password. If you have not
configured an uninstall password, select Uninstall at the top of the window.

4.2. Location Screen
The Bitdefender GravityZone tab from the Location screen allows you to perform
several tasks and view security events information.

● Manage automatic deployment settings for the Location

● Manage manual deployment or removal of the Bitdefender Agent for one or
more devices

● Configure deployment exclusions

● View deployment history

● Create scan tasks and take certain actions on multiple devices

● Manage the quarantine for the client

● View security events
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Deployment in Location screen

4.2.1. Deployment Settings
By clicking the Deploying Settings button in the upper right-hand side of the
Bitdefender GravityZone tab on the Location screen you are able to control how
the Automatic Deployment settings are applied to this location.

Deployment Settings in Location screen

To configure the deployment settings:

1. Specify the deployment package for installing the Bitdefender agent.

2. Select the targets for deployment:
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● Windows workstations

● Windows servers

● macOS machines

● Linux machines.

3. Click Save.

4.3. Computer Screen
The Bitdefender GravityZone tab on the Computer screen allows you to perform
several tasks, and view security events and Bitdefender agent information.

● Exclude or disable automated deployments from occurring on the specified
device.

● Manually trigger the installation or removal of the Bitdefender agent.

● View information relating to the Bitdefender agent.

● Manage the quarantine of the specified device.

● View security events.

● Queue a scan to run against the device in the GravityZone Control Center.

● View or change the computer papping to the GravityZone Control Center.

● Viewalerts on issues detected on device. The issuesmay refer to such situations
as macOS permissions for full disk access or kernel extensions.
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Computer screen

Note
Additional information will only be available after the computer has been mapped to
the correct device within the GravityZone Control Center.

4.4. Tasks and Actions
In this page you can create scan tasks for multiple computers at once.

1. In the Client or Location screen, go to Tasks and Actions.

2. Select one or more computers and click Create Scan.

3. In the configuration window, select the type of scan:

● Quick scan

● Full scan

● Memory scan

4. Optionally, enter a name for the scan task.

5. ClickScan. TheBitdefender pluginwill create a scan task inGravityZone console.
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4.5. Security Events
The Security Events section displays information regarding detections made by
Bitdefender protection modules and relies on the Event Push Service API from
GravityZone Control Center.
The following security events are available with the Bitdefender plugin:

● Advanced Threat Control

● Advanced Anti-Exploit

● Antimalware

● Antiphishing

● Endpoint Detection and Response

● Hyper Detect

● Network Attack Defense

● Ransomware Mitigation

● Web Traffic Scan

Each event corresponds to an alert you can configure in Tools > Bitdefender
GravityZone > Configuration > Alert Settings.
Security events also have associatedmonitors. For details on how to operate them,
refer to the “Monitors” (p. 32).
The Security Events section is available on the Client, Location and Computer
screens.
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Security Events > Advanced Threat Control

4.5.1. Advanced Threat Control
This page displays information regarding to detections made by the Advanced
Threat Control module. It includes details such as:

● Computer name

● Process path

● Exploit type

● Process status

● When the threat was last blocked

4.5.2. Advanced Anti-Exploit
This page displays information regarding to detections by theAdvancedAnti-Exploit
module. It includes details such as:

● Computer name

● Technique
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● Action taken on the exploited process

● Process ID

● Process path

● Parent process ID

● Parent process path

● CVE

● Detection time

4.5.3. Antimalware
This page displays information regarding to detections made by the Antimalware
module. It includes details such as:

● Computer name

● Malware name

● Malware type

● Infection status

● Infected file name

● Detection time

4.5.4. Antiphishing
This page displays information regarding to detectionsmade by theContent Control
module. It includes details such as:

● Computer name

● Threat type

● URL

● Status

● Timestamp

4.5.5. Endpoint Detection and Response
This page displays information regarding incidents monitored and reported by the
Endpoint Detection and Response module. The main details include:
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● Location (available in the Client screen)

● Computer name (available in the Client and Location screens)

● Incident ID

● Detection name

● ATT&CK techniques

● Severity

● Main action taken

● Last time the incident was updated with new information

Reporting on EDR incidents is much more complex. You can find all the details in
the tickets generated by these incidents in the Service Desk > Tickets section of
the ConnectWse Automate Control Center. Learn how tickets are generated in
ConnectWise Automate and ConnectWise Manage here.

4.5.6. Hyper Detect
This page displays information regarding to detections made by the Hyper Detect
module. It includes the following details:

● Location

● Computer name

● Malware type

● Malware name

● File path

● Fileless attack (yes or no)

● Attack type

● Status (action taken on)

● Detection time

4.5.7. Network Attack Defense
This page displays information regarding to detectionsmade by theNetwork Attack
Defense module. It includes details such as:

● Computer name
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● Attack technique

● Detection name

● Victim’s IP address

● Attacker’s IP address

● Port

● Action taken by Bitdefender

4.5.8. Ransomware Mitigation
This page displays information regarding to detections made by the Antimalware
module. It includes details such as:

● Computer name

● Attack type

● Ransomware source

● The number of encrypted files

● Detection time

4.5.9. Web Traffic Scan
This page displays information regarding to detectionsmade by theContent Control
module. It includes details such as:

● Computer name

● Threat type

● URL

● Timestamp

● Access to website

4.6. Managing Quarantine
The Quaratined Items page displays items that are in the GravityZone quarantine.
You can view this page on the Client and Computer screens.
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To delete or restore quarantined files, use the check boxes and click the Delete
Selected Items or Restore Selected Items buttons at the upper right corner of the
screen.
The Quarantined Items page requires Quarantine API.

Quarantined Items

4.7. Monitors
The Bitdefender plugin creates several internal monitors to trigger alerts in
ConnectWise Automate Control Center.
You can set an alert template for eachmonitor individually to take specific actions.
Monitors generate tickets and errors messages depending on the alert's context.
To access the internalmonitors for Bitdefender alerts, go toAutomation >Monitors
and click the Internal Monitors tab.
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Internal Monitors

4.7.1. Monitor Types
The following monitors are available with the Bitdefender plugin:

DescriptionMonitor Name

A Bitdefender security agent installation
process failed.

Bitdefender GravityZone - Installation
Failure

A Bitdefender security agent installation
process requires reboot to complete.

Bitdefender GravityZone - Installation
Requires Reboot

A Bitdefender security agent uninstall
process failed.

Bitdefender GravityZone - Uninstall
Failure

One or more Antimalware security events
have been detected. This monitor uses the

Bitdefender GravityZone -
Antimalware Event

Bitdefender GravityZoneAntimalware Event
(Consolidated) template, which requires
configuration. For details, refer to this
article.
An Advanced Threat Control (ATC) security
event has been detected.

Bitdefender GravityZone - Advanced
Threat Control Event

AnAdvancedAnti-Exploit security event has
been detected.

Bitdefender GravityZone - Advanced
Anti-Exploit Event

An Antiphishing security event has been
detected.

Bitdefender GravityZone -
Antiphishing Event
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DescriptionMonitor Name

An EDR incident has been detected.Bitdefender GravityZone Endpoint
Detection and Response

A Hyper Detect security event has been
detected.

Bitdefender GravityZone - Hyper
Detect Event

A Network Attack Defense security event
has been detected.

Bitdefender GravityZone - Network
Attack Defense

A Ransomware Mitigation security event
has been detected.

Bitdefender GravityZone -
Ransomware Mitigation

AWeb Traffic Scan security event has been
detected.

BitdefenderGravityZone -WebTraffic
Scan Event

4.7.2. Managing Monitors
You can do the following actions with Bitdefender GravityZone monitors

● Disable

● Delete and restore

Disabling Monitors
To disable a monitor, you have to modify the alert template:

1. In Automate Control Center, go to Automation > Monitors.

2. Click on the Internal Monitors tab.

3. Locate the monitor and double click to edit.

4. Go to the Alerting tab.

5. Under Alert Template select Default – Do Nothing in the drop-down list.

6. Click Save.

Deleting and Restoring Monitors
To revert a monitor back to its default state, you need to delete it and trigger
ConnectWise Automate database agent service restart.

1. In Automate Control Center, go to Automation > Monitors.

2. Click on the Internal Monitors tab.
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3. Locate the monitor, right-click and select Delete Monitor.

4. Restart the Automate database agent. To do this:

a. Go to System > Solutions > Plugin Manager.

b. Click Advanced in the upper right corner of the window.

c. In the drop-down menu, select Reload Plugins and Update Remote Agent
Plugins.

d. Confirm the database agent restart.

5. Close and open the Automate Control Center. Back in the Internal Monitors tab,
the monitor should be restored.

4.8. Audit Actions
Through audit actions, you can keep tracking of changes that usersmade tomade
manually to the Bitdefender plugin settings. To view them, go to System >
Configuration > Dashboard > Management > Auditing.

Audit Actions

The following auditing actions are available for Bitdefender GravityZone:

● Triggering Bitdefender agent installation.

● Triggering Bitdefender agent uninstallation.

● Changing location deployment settings.
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● Changing client mappings.

● Changing plugin settings.

● Changing exclusion settings on individual machines.
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