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1. INTRODUCTION

1.1. Scope of This Document

This document aims to explain how to configure ConnectWise and Bitdefender
Control Center, for the automatic ticketing and billing services to work.

This document is intended for Managed Services Providers with partner accounts
in the Bitdefender Control Center.

1.2. Bitdefender and ConnectWise

Bitdefender GravityZone is an enterprise security solution that helps organizations
to achieve the best protection and performance for their business needs. Control
Center, a centralized security management console, allows administrators to
remotely install and manage security for any endpoint, in any location and
environment. A local application called Bitdefender Endpoint Security Tools is
installed on each endpoint.

ConnectWise is a business management solution, assisting vendors and partners
to bring together products, services and people.

The two solutions work together through API keys generation, available within
ConnectWise. MSPs can automatically create tickets and billing procedures for
their customer companies, based on security services delivered by Bitdefender.

The ConnectWise integration allows the following actions:

1. Connect Bitdefender Control Center to a ConnectWise account. Configure a
new integration within Bitdefender Control Center and provide your ConnectWise
account details (URL, company name, public and private keys).

2. Setup the ticketing service. Once enabled within the Bitdefender integration
wizard, tickets are automatically created in ConnectWise for the following types
of events:

. Malware Outbreak. This type of ticket is triggered each time a specific
percentage of protected endpoints is infected with the same malware.

. Blocked URLs. This type of ticket is triggered when a protected endpoint is
trying to access a web address blocked through a security policy.

. Outdated clients. This type of ticket is triggered when the percentage of
outdated clients within a managed company has exceeded the defined

Introduction 1
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threshold. The threshold represents a percentage of the total number of
endpoints under a managed company.

3. Setup the billing service. This functionality is reporting to ConnectWise the
number of active protected endpoints for each managed company with a
monthly subscription. Based on these figures, ConnectWise can determine a
price and issue an invoice for each managed company, at the end of the month.
For this functionality to work, a pricing model has to be defined in ConnectWise
for each managed company.

4. Import ConnectWise companies to Bitdefender Control Center. You can easily
import your ConnectWise companies to Bitdefender Control Center:

« During the initial integration setup (wizard-guided).

. Ondemand, after setting up the ConnectWise integration, using the options
available in the Companies page.

Introduction 2
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2. INTEGRATION PREREQUISITES

To connect your Bitdefender Control Center account to ConnectWise, you must
meet the following requirements:

Bitdefender Control Center partner account.
Monthly Usage license key issued by Bitdefender.
ConnectWise User Account.

API Key generation, required for setting up the ConnectWise integration with
Bitdefender Control Center.

ConnectWise companies must be successfully imported to Bitdefender Control
Center.

Integration Prerequisites 3
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3. SETTING UP CONNECTWISE WITH API KEYS

Log in to ConnectWise to start the configuration. We recommend using the
ConnectWise on premises client rather than the web client.

You need to generate API keys for authentication. These authentication parameters
are unique to ConnectWise Members, granting them access to company resources.

To generate API keys:
1. Go to System > Security Roles.
2. Click + New Item to create a Security Role and type a name in the Role ID field.

Security Roles > New Role
New Role

< B B < O

New Role

Role ID: new security role

New Role

3. Click @ Save.
4. Edit the Security Role to add the following permissions:
. Companies > Company Maintenance: Inquire level set to All
. Finance > Agreements: Add Level, Edit Level and Inquire level set to All

Important
This feature is unavailable for Basic Plan accounts.

« Procurement > Products: Inquire level set to All

« Procurement > Product Catalog: Inquire level set to All

« Project > Project Ticket Tasks: Inquire level set to All

. Project > Project Tickets: Inquire level set to All

. Service Desk > Service Tickets: Add Level and Inquire level set to All

Setting up ConnectWise with API keys 4
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Security Roles > Security Modules

Security Modules for Role - new security role

Role:  New security role v
( 4+ BB QD Hoyy @
~ Add Level Edit Level

~ Companies
~ Finance

v Marketing
v Procurement
v Project

v Sales

v Service Desk
v System

v Time & Expense

Security Modules

Important

Delete Level

Inquire Level

Last Update

06/27/2017
06/27/2017
06/27/2017
06/27/2017
06/27/2017
06/27/2017
06/27/2017
06/27/2017
06/27/2017
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Updated By
Training Admin3
Training Admin3
Training Admin3

Training Admin3
Training Admin3
Training Admin3
Training Admin3
Training Admin3

Training Admin3

Product Catalog is displayed as Product Entry in all versions prior to 2017.5.

5. Create an APl Member as follows:
a. Go to System > Members.
Go to the APl Members tab.

® o0 T

Click B Save to apply changes.

Setting up ConnectWise with API keys

Click + New Item to add a new entry.

Fill in the mandatory fields and assign the previously created Security Role.



¢

" -

Bitdefe der Gkvityoﬁg

unfollow the traditional

Members - APl Members > Details
John Doe (MemberiD)

Details Skills Certification Delegation Accruals APl Keys APl Logs

= | + B @ | [ | DeleteUnused Timesheets |

<

i Updated: 5/29/2017 12:09:56 PM by Admin3

Member ID: - License Class: APl v

Password (32 max): =  =swwss Disable Online Enable Mabile Edition

Confirm: T e Type: -

First Name: = Employee [D: | |
Middle Initial: [ ] vendorhbr | |
Last Name: - Notes: ®

Report Card: ~ | Time Zone: * | US Eastem ~ | Country: -

Pheta: | | Browse.. | W a

Contact Information

Default  Email = Default Phone =
S os O | e —
Mobile: O [ ] (Mol @ [+17010101010 = |
e O[] tm O | | e
Role ID: * newAPl w | Level: * | Corporate ~
[] Manage Administrator Name: | Comporate ~

Member ID

Go to the API Keys tab.
Click + New Item to add a new entry.
Write down the name in the Description field.

© © N o

Click B Save to generate Public and Private API Keys.

Setting up ConnectWise with APl keys
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Members - APl Members > Public AP| Keys » APl Keys
John Doe (MemberiD)

Details Skills Certification Delegation Accruals APl Keys API Logs @3
< + B B © Hsoyv i
Public APl Key
Description: +  hasic auth
Public Key: *
Private Key: *

Note: The private key is only available at the time the key is created. Please make a note of it.

API Keys

Important
The Private Key is only available the first time you create it. Please make a note of

it to be later used in the Configure ConnectWise Integration screen.

Setting up ConnectWise with API keys
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4. MANAGING THE CONNECTWISE INTEGRATION WITHIN
BITDEFENDER CONTROL CENTER

4.1. Configure the ConnectWise Integration

1. Login to Bitdefender Control Center using your partner credentials.

2. Point to your username in the upper-right corner of the console and choose
Integrations. The Integrations page will show up.

Welcome, Partner

My Account

My Company

Integrations

Cradentials Manager

Logout

Cloud Console Integration

3. Click the ® Add button at the left side of the table.

4. Click Add ConnectWise Integration link. The integration wizard will appear.

Managing the ConnectWise Integration within Bitdefender Control Center 8
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Configure ConnnectWise integration setiings X

Enter Company Administrator Account Details

URL: * https://new-api.connectwise.com
Company: * Company

Public Key: * ntlnr24ak512

Private Key: * ‘ wseesenasennseny

Options.

Receive tickets for: Malware Outbreak

Threshold: 5 E
Blocked URLs
Outdated clients

Threshold: 50 H

Send billing information

cance' m

Integration Settings

5. Under the Company Administrator Account Details section, enter the required
ConnectWise credentials:

« URL: the ConnectWise server address.
« Company: your ConnectWise Company ID.

. Public Key and Private Key : generated after you created an AP Member in
ConnectWise.

6. Under Options, define the services you want to use with the ConnectWise
platform:

. Select the type of tickets you want to automatically create from Bitdefender
Control Center:

— Malware Outbreak. This type of ticket is triggered each time a specific
percentage of protected endpoints is infected with the same malware.

Managing the ConnectWise Integration within Bitdefender Control Center 9
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— Blocked URLs. This type of ticket is triggered when a protected endpoint
is trying to access a web address blocked through a security policy.

— Outdated clients. This type of ticket is triggered when the percentage of
outdated clients within a managed company has exceeded the defined
threshold. The threshold represents a percentage of the total number of
endpoints under a managed company.

For more details regarding the tickets workflow, refer to the Ticketing Setup
chapter.

Send billing information enables Bitdefender to report the number of active

protected endpoints for each managed company. For the billing service to

work, you need to provide the following information:

— Agreement Type: enter the name of the previously created Agreement
Type.

— Product: enter the relevant Product for your managed company.

For more details regarding the billing workflow, refer to the Billing Setup
chapter.

7. Click Save. Wait until Bitdefender Control Center connects to ConnectWise with
the provided credentials.

8. After the connection with ConnectWise has been established, the wizard will
load all your managed companies. Import to Bitdefender Control Center the list
of desired companies, as follows:

a. Select the companies ready to be imported. Use the search box under

Company Name or the filter under Company Status to easily find a specific
company.

. Choose the Licensing type for the imported companies. Each company under
Bitdefender Control Center must have the licensing option filled in. You can
opt between the following license types:

. Trial. A 30 days trial license key is automatically assigned to each
imported company.

« Monthly Subscription. Each imported company will share the seats
available on your Bitdefender monthly usage license key.

Managing the ConnectWise Integration within Bitdefender Control Center 10
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Import companies from ConnectWise ®

n Information

You can always update your imported companies by going to Companies > Add > Import companies from ConnectWise

Company Name Company Status
Your Company Active
Company_1 Active
Company_2 Active
Company_3 Credit Hold
Company_4 Active
Company_5 Active
Company_6 Active
Company_7 Attention needed
Company_8 Active
Page 1 of 26 —  LastPage | 20 v 514 items

Licensing type for imported companies: | Trial

Flose

Import Companies from ConnectWise

Warning

For the billing integration to work, managed companies must have a
monthly subscription.

9. Click Import. Wait until your ConnectWise companies are imported to Bitdefender
Control Center. Imported companies will appear in the Network group, under
your Network inventory. You can also edit each company using the options
available in the Companies page.

Managing the ConnectWise Integration within Bitdefender Control Center 11
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Bitdefender
,

Dashboard ' »E - ® ® Sy

Network Name os. »
Packages
Tasks

Policies

Network Inventory

Once configured, the ConnectWise integration will be visible in the Integrations
page.

4.2. Edit the Settings for ConnectWise Integration

To edit the settings of your ConnectWise integration, all you need to do is to click
ConnectWise in the Integrations page. You will be able to change the integration's
credentials and modify the selected features.

When done, click Save to apply changes.

Important

Importing new companies from ConnectWise is not available while editing the
integration’s settings. After the first ConnectWise integration setup, you can import
new ConnectWise companies only by using the options available in the Companies
page. For more information, refer to the Managing ConnectWise Companies in
Bitdefender Control Center chapter.

4.3. Disable the ConnectWise Integration

To disable the ConnectWise integration, go to the Integrations page. Select its
checkbox and click the = Delete button, at the left side of the table. The integration
is removed once you have confirmed the action.

Managing the ConnectWise Integration within Bitdefender Control Center 12
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5. TICKETING SETUP

Bitdefender Control Center can be configured to automatically create tickets in
ConnectWise for the following type of events: malware outbreak, blocked URLs
and outdated clients.

For the ticketing service to work, the following conditions must be fulfilled:

1. Atleast oneticket typeis enabled and configured as required in the ConnectWise
integration wizard.

2. Bitdefender Endpoint Security Tools (the client security software) is installed
on endpoints belonging to your managed companies.

When a ticket is created, Bitdefender sends a ticket summary and a detailed
description of the issue to ConnectWise.

Once you have evaluated and eventually solved the ticket, you can close it. To view
tickets in ConnectWise:

1. Go to Service Desk > Service Ticket Search.
2. In the Company column, search for the company you are interested in.
ConnectWise will display all the tickets created for that company.

Service Ticket Search

Service Ticket Search

4+ & Actions ™ SEARCH CLEAR Export  View v @ < 1-30t3v >

] B.. Ticket Type Ticket # Priority Company Summary Description To.. Budget Comtact Status

Service Tic v | All v ConneciWise malware

Service Ticket 462 Co i Malware outbreak detected 0.00 ConnectWise New (not responded)

O
B

=]

0.00 ConnectiWise  New (not responded)

]

ConnectiVise Malware outbreak detected

oo
B

|
| Service Ticket 46
|

Service Ticket 46, Co Malware outbreak detected 0.00 ConnectWise New (not responded)

Service Ticket Search

5.1. Malware Outbreak Tickets

A malware outbreak ticket is created in ConnectWise each time a specific
percentage of protected endpoints is infected with the same malware.

You can configure the malware outbreak ticket threshold in the ConnectWise
integration wizard.

Ticketing Setup 13



unfollow the traditional

BltdefenderGrawt\/Zome

For example, when the threshold is set to 5 for a company, and a virus is detected
on 5 out of 100 endpoints, a malware outbreak ticket will automatically be created
for that company, in ConnectWise.

Options

Receive tickets for: Malware Outbreak
Threshold 5 E
Blocked URLs
Qutdated clients

Send billing information

Cance' ﬂ

Malware Outbreak

Note
Another malware outbreak ticket can be generated if the same infection is still
detected in the network, twenty four hours after the initial ticket was raised.

5.2. Blocked URLs Tickets

Blocked URLs tickets are automatically created when a protected endpoint is trying
to access a web address that is blocked through a security policy.

Important

Bitdefender Control Center creates only one Blocked URLs ticket for the same web
domain. For example, Bitdefender Control Center will not generate a new ticket when
another URL path or sub-domain is getting blocked within the same company. This
can happen regardless of a ticket's closed status.

New Blocked URLs tickets can be generated only for other domains that are blocked
through the security policy.

In the Bitdefender Control Center, you can configure the security policies to block
web traffic by categories, and also by specific URLs:

. Blocking website categories. To view the policy web control settings, open the
Policies section and go to Content Control > Web > Web Control Settings >

Ticketing Setup 14
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Categories. In this section, you can enable the web categories filter and define
web rules (allow or block) for each web category.

Bitdefender

GravityZone

Dashboard £+ General G Web Access Control
Network @ Antimalware +

Pack ‘Web Control Settings v
ackages 42 Firewall + -Block
Tasks = Content Control - Schedule Scheduler  Categories  Exclusions
Policies O -Allow
Traffic Web Categories Filter
Assignment Rules e Antiphishing
- Aggressive Permissive - Only high risk categories are blocked
Reports 3 .
Data Protection Protection agains - Normal The Web Category Filter will be automatically set up to allow al categor
Quaraniine ) ) igars, Pornogral
L -
fEsiETE [ Protection agains O - Permissive Suicide and Narcotics
Companies
¥ Device Control + - Custom
Accounts Treat Web Categories as exceptions for Web Access
=) Relay +
User Activity Show detailed alerts on client
E3 Exchange Protection  +
Configuration
S ~ * Web Rules X Block All
@ Encryption +
Update

Web Control Settings: Categories

For example, if you assign a policy to block social network websites, and one
endpoint is trying to access www.linkedin.com, a ticket will be created in
ConnectWise for the parent company. The ticket description will specify that
an URL has been blocked for the www.linkedin.com domain.

Blocking specific URLs. You can also configure security policies to block specific
URLs, by enabling web exceptions and adding the specific URLs that you want
to block. To accomplish that, open the Policies section, go to Content Control
>Web > Web Control Settings > Exclusions and define the settings accordingly.

Ticketing Setup 15
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Bitdefender
GravityZone

Dashboard £+ General B3 Web Access Control
Network @ Antimalware
Web Control Settings V
Packages % Firewall - Block 9
Tasks = Content Control -Schedule | cheduler  Categories  Exclusions
Policies Traffi O - Alow
raffic Use Exceptions
Assignment Rules - % Antiphishin
web G Antiphishing | [ o0, wabitdefender.com or = bitdefender com) Block
Reports _
Data Protection Protection aga{ (5} Export (=) Import

Quarantine )
Applications Protection agaf

‘Web Address Permission
Companies
) Device Control linkedin.com Block

Accounts
") Relay Page | 1 | oft 20

User Activity

E3 Exchange Protection
Configuration Cancel

@ Encryption

Update

Web Control Settings: Exclusions

5.3. Outdated Clients Tickets

Outdated Clients tickets are created when the percentage of outdated clients within
amanaged company has exceeded the defined threshold. The threshold represents
a percentage of the total number of endpoints under a managed company

Bitdefender Control Center reports that the Bitdefender Endpoint Security Tools
client is outdated if either the product, or the virus signatures have not been updated
in the first twenty four hours following an update release.

You can configure the threshold for the Outdated Clients ticket in the ConnectWise
integration wizard.

For example, for a threshold of 50, when the number of outdated clients of a
company reaches 50 out of 100 endpoints, an Outdated Clients ticket will
automatically be generated for that company in ConnectWise.

Note
Another Outdated Clients ticket for the same company can be generated only if the
current ticket had been manually closed in ConnectWise.

Ticketing Setup 16
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6. BILLING SETUP

The billing integration allows you to receive Bitdefender Control Center usage
reports for each managed company in ConnectWise.

Important
This feature is unavailable for Basic Plan accounts.

Once the billing integration has been enabled, Bitdefender Control Center sends
out the number of active computers protected with Bitdefender Endpoint Security
Tools to the configured ConnectWise server.

A Bitdefender Endpoint Security Tools client is considered active only if a connection
to the the Bitdefender Control Center is established, at least once in a given month.

For the billing service to work, the following conditions must be fulfilled:
1. A pricing model is defined in ConnectWise for each managed company.

2. The billing service is enabled and configured as required in the ConnectWise
integration wizard.

Important
For the billing service to work, make sure to correctly input the required information
in the ConnectWise integration settings. All entries are case sensitive:

« Agreement Type: enter the name of the previously created Agreement Type
name.

« Product: enter the relevant Product for your managed company.

Send billing information

Agreement Type: * System Support
oo |

Product: System Support

cancel “

Send Billing Information

3. Managed companies are licensed with a monthly subscription.

At the beginning of each month, Bitdefender Control Center creates a usage record
for each managed company in ConnectWise. The usage record remains open during

Billing Setup 17
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the entire month. When a new client is installed in the same company, the usage
record is automatically updated with the new count. New additions will be visible
after a time period of four hours.

To view the usage records of a company in ConnectWise:
1. Go to Finance > Agreements.

2. Search for the previously created Agreement Type.

3. Go to the Additions tab.

Agreement Search > Additions
CwDemoAgreementType

Agresment Additions 2 Adjustments 0 Agreements 0 Work Roles D Work Types 0 Sites 0 Invaice 0 Service 0 Time |

¢ 4 Actions~  SEARCH CLEAR Export  View (No View) v < -zofzvw
O Sequence  Effective Cancelled ProductID  Description Quantity Price Ext Price
All v |
O 1.00 06/30/2017 Product1  Product1 0.00 $10.00 $0.00
O 2.00 07/03/2017 Product1  Product 1 0.00 510.00 50.00
Additions

An Addition will be created at the start of the month and updated incrementally.
Each Addition will be counted as a new value by the Update Request Processor,
allowing the user to know exactly how many endpoints are active in a given
month.

Important

New Additions cannot be added to an upcoming Billing Start Date. This can only
be done after the service period start date.

Billing Setup 18
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7. MANAGING CONNECTWISE COMPANIES IN BITDEFENDER
CONTROL CENTER

Importing your managed companies from ConnectWise to Bitdefender Control
Center can be done in two stages:

1.

At the final step of the initial ConnectWise Integration Setup. During further
edits, the companies import options are no longer available from the
ConnectWise integration.

At any time, in the Companies page from Bitdefender Control Center:

a. Log in to Bitdefender Control Center using your partner credentials.
b. Go to the Companies page.
c. Click the @ Add button from the upper left side of the table.

Type + Managed License usax ge License validity

ppppppp

Partner. Yes Licensed: 5, Unlicensed: 0, Reserved: 2, Total: ... never

ensed: 0, Total: 255 28 August 2017

Total: unlimited, Maiboxes: 0/unlim.. expired

Import Companies from ConnectWise

. Click Import companies from ConnectWise. Wait until Bitdefender Control

Center retrieves the information from ConnectWise.

. Select the companies that you want to import and specify their licensing

type using the options available at the lower side of the window. You can

opt between the following license types:

. Trial. A 30 days trial license key is automatically assigned to each
imported company.

« Monthly Subscription. Each imported company will share the seats
available on your Bitdefender monthly usage license key.

Warning

For the billing integration to work, managed companies must have a monthly
subscription.

Click Import. Wait until ConnectWise companies are imported to Bitdefender
Control Center.

Managing ConnectWise Companies in Bitdefender Control Center 19
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